Categories
Lucid Builder v4

Lucid Builder Display Settings

This option applies to Windows users only

Depending on your Windows display settings (e.g. scale settings etc) you may find that the Lucid Builder interface appears blurry with the icons appearing somewhat jagged. This can be easily corrected by using the High DPI Scaling Override settings for the Lucid executable.

First ensure the Lucid Builder is closed, then find, using Windows Explorer, the Lucid Builder executable, installed by default to:

C:\program files\Lucid4\Lucid4 Builder.exe

Within Windows Explorer right click on the Lucid Builder executable. Select the Properties menu item from the context pop-up menu. From the Properties dialog that will open, select the Compatibility tab as show below.

Lucid Builder Executable Properties High DPI Settings
Lucid Builder Executable Properties High DPI Settings.

Click on the Change high DPI settings button. This will open the high DPI settings dialog.

Lucid Builder Executable High DPI Settings dialog
Lucid Builder Executable High DPI Settings dialog.

Click on the Override high DPI scaling behavior option and select the ‘System (Enhanced)‘ option as shown below.

Lucid Builder Executable Properties high DPI System Enhanced option
Lucid Builder Executable Properties high DPI System (Enhanced) option.

Restart the Lucid Builder. You should now see the interface display is now corrected.

Categories
Lucid Builder v4

Lucid Builder Check Media

The Builder Media Check function will parse either the Feature or Entity Tree media attachments and check on the corresponding files for their specified file system location. If any missing media items are reported on a per Feature or Entity basis depending on which check option is currently selected.  

Lucid Builder Check Media dialog
Lucid Builder Check Media dialog – Features check example.
Lucid Builder Media Check dialog - Entities missing media example
Lucid Builder Media Check dialog – Entities missing media example.

Tip

You can leave the Media Check dialog open while you review/fix the missing media list in the Builders main interface. You can also copy and paste the report text, if needed.

Categories
Lucid Builder v4

Lucid Builder Check for Updates

You can check for updates to the Lucid Builder by using the ‘Check for updates’ option via the Help menu.

An Internet connection is required for the Builder to check for an update.

Lucid Builder Check for Updates progress dialog
Lucid Builder Check for Updates progress dialog.

The Lucid Builder will show its progress on checking for an update. If an update is found you will be prompted if you wish to download and install it. Ensure the Lucid Builder is closed prior to installing the new update.

Lucid Builder Check for Updates Message Dialog
Lucid Builder Check for Updates Latest Builder already installed message dialog.
Categories
Lucid Builder v4

Lucid Builder About Dialog

Lucid Builder About Dialog
Lucid Builder About Dialog

The About dialog will allow you to find your licence details and the full version information of the Lucid Builder.

Categories
Lucid Builder v4

Lucid Builder Main Toolbar

The Lucid Builder Toolbar provides convenient shortcuts to the actions available from the Menu system.

Lucid Builder Main Toolbar
Lucid Builder Main Toolbar
Categories
Lucid Builder v4

Lucid Builder Help menu

Lucid Builder Help menu
Lucid Builder Help menu.

Help icon Help

Opens the Lucid Builder on-line help, in your preferred web browser.

Check for updates icon Check for Updates…

Check for any updates to the Lucid Builder that are available for your edition. An online connection is required for this action to function.

Please see Checking for Updates help topic for additional information.

About icon About Lucid Builder…

Opens the About dialog where Lucid Builder version and copyright information can be found.

Categories
Lucid Builder v4

Lucid Builder Window menu

Lucid Builder Windows menu
Lucid Builder Windows menu.

The Lucid Builder allows multiple dialogs to be opened at the same time. The Windows menu shows the currently opened dialogs, which you can select to bring them forward above the main Builder interface.

Windows Bring to Front icon Bring all to front

All opened dialogs will be brought to the front of the main Lucid Builder interface.

Categories
Lucid Builder v4

Lucid Builder Tools menu

Lucid Builder Tools menu
Lucid Builder Tools menu.

Add Items icon Import Items…

Opens either the Features or Entities Import Items dialog depending on which panel (Features or Entities) you have selected. The Import Items dialog allows you to quickly build Feature trees or Entity trees very quickly by either typing or pasting existing data.

See the Adding items to the Feature and Entity trees help topic for further information.

Check Media icon Check Media…

Opens the Check Media dialog where any missing media for Features or Entities will be reported.

See the Check Media help topic for further information.

Key Reporter icon Key Reporter…

Opens the Key Reporter dialog. The Key Reporter allows you to query many aspects of your key such as unscored Entities, items without media, items needing revision etc.

See the Key Reporter help topic for further information.

Edit Language icon Edit Builder Language…

Opens the Language Editor for the Builder interface.

See the Multilingual support help topic for further information.

Edit Language icon Edit Player Language…

Opens the Language editor for the Player interface.

See the Multilingual support help topic for further information.

Categories
Lucid Builder v4

Lucid Builder Key Menu

Lucid Builder Key menu
Lucid Builder Key menu.

Media sub menu

Lucid Builder Key menu - Media sub menu
Lucid Builder Key menu – Media sub menu.

Remove Feature Media icon Remove Feature Media…

Enables the removal of either all media from Features and States, or the removal of image media or text media from the selected Feature or State.

See Removing Media help topic for more information.

Remove Entity Media icon Remove Entity Media…

Enables the removal of either all media from Entities, or the removal of image media or text media from the selected Entity.

See Removing Media help topic for more information.

Refresh icon Update Thumbnails

Forces the Builder regenerate the keys thumbnails from the attached images. This is useful if you have adjusted the preferred thumbnail size in the Key Options or have changed out images, outside the scope of the Builder (I.e. Via the file system). Regenerating thumbnails can be an intensive process for large keys with lots of images. You will be asked to confirm the action.


Descriptions sub menu

Lucid Builder Key menu - Descriptions sub menu
Lucid Builder Key menu – Descriptions sub menu.

Edit Template icon Edit Template…

Opens the Natural Language Template Editor dialog.

Attach HTML icon Attach Descriptions

Attaches HTML based descriptions (generated by the Natural Language generator) to all Entities in the Entities tree. These can be individually added (or removed) via the Media Properties panel for the selected Entity.

Remove HTML icon Remove Descriptions

Removes all HTML based descriptions (generated by the Natural Language generator) from the Entities in the Entities tree. These can be individually removed (or added) via the Media Properties panel for the selected Entity.

Refresh icon Update Descriptions

Forces the regeneration of all Entity Natural Language description files, created by the Builder, based on your template and transform file.


Scores sub menu

Lucid Builder Key menu - Scores sub menu
Lucid Builder Key menu – Scores sub menu.

View Dependencies icon View Dependencies

Opens the View Dependencies dialog that allows you to check on your dependency scoring. See the View Dependencies help topic for further information.

View Scope icon View Scopes

Opens the View Scopes dialog that allows you to easily view your scoped and not scoped Features. See the View Scopes help topic for further information.

Subsets icon View Subsets

Opens the View Subsets dialog that allows you to review your Subsets (and contained Features or Entities). See the View Subsets help topic for further information.


Deploy Key icon Deploy Key…

Opens the Deploy Key dialog. See the Deploying a key help topic for further information.

Preview icon Preview Key

Allows you to preview your key by opening it in the Lucid Player, via your preferred web browser.

Key Options icon Key Options…

Opens the Key Options dialog, which allows you to set a number of preferences for your key. See the Setting key options help topic for further information.

Categories
Lucid Builder v4

Lucid Builder View Menu

Lucid Builder View menu
Lucid Builder View menu.

Language icon Language…

Opens the Language selection dialog for the Lucid Builder. A language file may be another language from what you are using (E.g. English, Spanish or Mandarin etc.), or a language can simply be a variant on a language, with customised strings to suit the key’s topic. For example, you may have an English language file variant for weeds, where all the terms for ‘Entity’ and ‘Entities’ are replaced with ‘Weed’ and ‘Weeds’.

See the Multilingual Support help topic for additional information.

Font icon Font…

Opens the Font selection dialog. You may prefer a different font than the default system font. Or your language may require a specific font, not set via your operating system.

Font Size

Lucid Builder View menu - Font Size sub menu
Lucid Builder View menu – Font Size sub menu.

Increase Font Size icon Larger (ctrl+ =) ( + =)

Increases the font size within the Lucid Builder.

Decrease Font Size icon Smaller (ctrl+ -) ( + -)

Decreases the font size with the Lucid Builder.

Filter Feature Tree

Lucid Builder View menu Filter Feature Tree sub menu
Lucid Builder View menu Filter Feature Tree sub menu example.

The options within the Filter Tree sub menu depend on what Feature Subsets have been created. All Feature Subsets will be listed as menu options. Each available Feature Subset can be toggled on or off by selecting or un-selecting the Subset within the menu. When a Feature Subset is toggled on, the Features scored for that Subset will be displayed, while non-scored Features for that Subset will be hidden. That is only Features that are scored in the selected Subsets will be displayed.

Filter Entity Tree

Lucid Builder View menu Filter Entity Tree sub menu example
Lucid Builder View menu Filter Entity Tree sub menu example.

The options within the Filter Tree sub menu depend on what Entity Subsets have been created. All Entity Subsets will be listed as menu options. Each available Entity Subset can be toggled on or off by selecting or un-selecting the Subset within the menu. When an Entity Subset is toggled on, the Entities scored for that Subset will be displayed, while non-scored Entities for that Subset will be hidden. That is only Entities that are scored in the selected Subsets will be displayed.

Refresh icon Refresh Item Trees

This option can be used to force the Lucid Builder to re-render the Feature and Entities trees. This can be useful for example, if you have change screen resolutions or resized thumbnails outside the scope of the Builder and want it to refresh the display.

Display

Lucid Builder View menu Display sub menu
Lucid Builder View menu Display sub menu.

Feature thumbnail icon Feature Thumbnails

Toggle on or off the display of Feature (and States) thumbnails within the Features tree. The size of the thumbnail is set via the Key Options dialog.

Entity Thumbnail icon Entity Thumbnails

Toggle on or off the display of Entity thumbnails within the Entities tree. The size of the thumbnail is set via the Key Options dialog.